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ATA Provides High-Value Engineering Services With 

Expertise in Design, Analysis, and Test

ATA Engineering helps to overcome product design challenges across a range of industries

Consumer 

Products

Aerospace Robotics & 

Controls

Industrial & 

Mining 
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Defense

Themed 

Entertainment



3

ATA is a Value-Added Reseller for Siemens Digital 
Industries Software

ATA offers training, free resources, and hotline support for a 

variety of Siemens products.

 Siemens product lines we support include:

 Simcenter STAR-CCM+

 Simcenter Femap

 Simcenter Nastran (formerly NX Nastran)

 Simcenter 3D

 NX CAD & CAM

 Teamcenter

 Solid Edge

 Contact the hotline at 877-ATA-4CAE or 

http://ata-plmsoftware.com/support

 Developer of the official Simcenter Nastran training materials

 Preferred North American provider of Simcenter Nastran training

 Recognized as Smart Expert Partner with validated expertise in 

Femap, STAR-CCM+, and Simcenter 3D

http://ata-plmsoftware.com/support
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www.ata-plmsoftware.com

Visit Our Website for Product Information and Free Resources

http://www.ata-plmsoftware.com/
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Simcenter Femap Direction

35+ Years Dedicated to the Needs of the FEA Analyst!

Maximize efficiency of FEA tasks

• Efficient creation of high fidelity FE models that accurately represent real-world 

engineering problems

• Intuitive interpretation of analysis results to improve the design and 

performance of engineered products

Build upon strong Simcenter Femap capabilities

• Geometry idealization and processing for FE models

• Powerful meshing, model creation and interactive editing

• In-depth support for industry standard solvers

• Flexible customization tools to streamline analysis processes
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Simcenter Femap Roadmap – Update Release Cadence

Feature Release Every Six Months
Database Change, UI Updates including 

Localization, Licensing Updates – April - October

Maintenance Release – If Required
Database, UI, Licensing Unchanged – Bug 

Fixes/Critical Updates Only

Maintenance Release – If Required
Database, UI, Licensing Unchanged – Bug 

Fixes/Critical Updates Only

Six Month

Cycle
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Simcenter Femap Roadmap – Update Release Cadence

Feature Release – April/October

• New Features

• Expanced Functionality

• Database Changes

• API Expansion

• Will Require Licensing Update, Localization Update

Maintenance Release 

• Bug Fixes

• Minor Enhancements without User Interface Changes

• Working to Modernize Installer – Maintenance Releases as 

Patches, not full Installs

• Simcenter Nastran Update
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Simcenter Femap v12.0 and Beyond Roadmap

Simcenter Femap v12.0

October 2018

Simcenter Femap v2019.1

April 2019

Simcenter Femap v12.01

December 2018

Simcenter Femap v2020.1

November 2019

Simcenter Femap 2020.2

May 2020

F
M

F

F F

M

M

Simcenter Femap 

v2020.1 MP 1 

December 2019

Simcenter Femap 

v2020.1 MP 2 

February 2020

M
M

Simcenter Femap 

v2019.1 MP 1 

February 2020

M
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Simcenter Femap v2020.2 – What’s New

Performance Improvements

• Connect->Automatic command

• 3x-5x improvement in models with a large number of connections

• Geometry, Copy/Rotate/Reflect: Mesh, Copy/Rotate/Reflect; and Move commands

• Significant improvements have been made to both the copy/move phase of these commands and 

the redrawing phase

• Most noticeable improvement will be in large models when copying small portions of the 

model…potentially 40x faster.

• Length-based operations on Curves

• Impacts Mesh Sizing and Coordinate methods such as Along Curve, Length Along and Midpoint by 

making these methods both Faster and More Accurate

• Mesh Sizing 2x-3x faster on large model
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Simcenter Femap v2020.2 – What’s New

Performance Improvements

• Commands which can be “Aborted”

• Many Checking and Listing commands can be aborted while doing computations or listing results.

• Anywhere from 2x-100x improvement in speed of these commands with only slightly slower abort 

reaction time

• Largest improvements in the Tools->Check and Tools->Mass Properties commands

• Output Process

• 30%+ improvement in the Envelope, Linear Combinations, and RSS combinations

• Nastran Model Read

• Almost 2x improvement in importing large input files

• ANSYS Results Read

• 2x-3x improvement when reading results from non-compressed RST files
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Simcenter Femap v2020.2 – What’s New

Performance Improvements – Graphics

• Performance

• Entity creation (especially in PG*)

• Minimize free face evaluation

• Minimize full graphics regenerations

• Creating a single entity when the model 

is already large was slow in PG*.

• Creating a single rigid element in a 

model with 3.3 million 10-noded 

tetrahedral elements took 29 seconds 

in 2020.1, but now takes 0.3 seconds 

(~95x improvement)

• Some improvement to entity copy in large 

models but not as significant as in 

creation
*PG = Performance Graphics in Simcenter Femap
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Simcenter Femap v2020.2 – What’s New

Performance Improvements – Graphics

• Added Crtl-G Group Evaluate option to Graphics

tab of File->Preferences, which performs Group-

>Operations-> Evaluate on all groups currently 

visible when using Window-> Regenerate (Ctrl+G

Shortcut Key). Helps when creating entities into 

the displayed group.

• Added Disable Abort option to Graphics tab of 

File->Preferences to disable checking for user 

aborts while drawing

• Max VBO MB and Min VBO B are available to 

specify when Best Possible is enabled

• Improved performance of thumbnail generation for 

large models from 30 seconds to 10 seconds
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – High DPI Support

New Icons

• Icons were redrawn with a modern 

style and color palette

• Colors selected to provide 

enhanced contrast making 

selection easier

• Consistent theme throughout 

Femap

• Designed to maximize familiarity to 

minimize learning curve

Old New
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – High DPI Support

New Icons – All 1600+ Completed in v2020.2!

• Vector assets of all icons allow for Femap to fully 

support high resolution (4K) displays

• UI scaling - Full high DPI support in 2020.2 now 

available!!!

• Other options can be set with Preference:

• Disabled – Femap is drawn at 100% resolution, 

however text and icons can be small and hard to read

• Handled by Windows – Femap is scaled 

at the Windows scaling setting via 

extrapolation; leads to blurry text and 

icons

100%

150%

Example icons

200%

100%

150%

200%
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – High DPI Support

High DPI Support – v2020.2 examples on 4k monitor

High DPI Aware Windows Native Scaling No Scaling
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Curve Connectivity

Curve Connectivity in View->Options 

colors Curves by level of connectivity

• Override curve color based on 

surface connectivity

• Free – 1 surface attached

• Manifold – 2 surfaces attached

• NonManifold – more than 2 

surfaces attached or “T-junction”

• Wirebody - 0 surfaces attached 

(not common as Wirebody entities 

cannot be created in Femap)
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Curve Connectivity

Before NonManifolod Add – No NonManifold Curves Exist After NonManifolod Add – NonManifold Curves Shown in Yellow
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Renumbering

Improved Renumbering commands to 

provide better control when choosing to 

offset IDs

• Replaced old “Constant Offset” option 

with new Renumbering Options section

• Compress – Specify Starting ID and 

optionally Increment

• Offset To – Specify Starting ID

• Offset By – Specify ID Offset
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Copy/Save Formats

Enhanced Copy to Clipboard and Save to File commands for the Data Table, Connection Editor, 

Mesh Point Editor, Function/Table Editor and Entity Editor to copy/save data using formatted HTML.

ID Prop ID Type Topology Color Layer Formulation C1 C2 C3 C4
Orientation 

Vector

106
101..Upper Wing 

Skin
PLATE Quad, 4-noded 0 1 None 204 205 209 10

214
5..Upper Stringer -

T Section
BEAM Line, 2-noded 124 1 None 200 201 0., -1., 0.

97
101..Upper Wing 

Skin
PLATE Quad, 4-noded 15 1 None 6 322 197 7

Improves formatting when pasting into Office Tools and allows viewing of saved files with standard browsers.
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Send to Excel

New technology in Simcenter 

Femap offers ability to 

transfer data from dialog 

boxes and panes directly to 

Microsoft Excel

• Standard Entity Selection

Examples of dialog boxes 

which have Send to Excel 

commands or icons to 

transfer data are:

• Layup Editor
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Send to Excel

Various dockable panes in Femap 

are now outfitted with Send to Excel 

commands or icons

Typically located next to Copy/Save 

icons or on Copy to Clipboard menu

Data is sent with HTML Formatting

• Organized

• Clean look and feel

• Easy to manipulate column width 

and other features of the table
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Send to Excel

Send to Excel command in Charting

pane simultaneously transfers:

• XY Data Pairs for ALL Data 

Series currently visible in the 

Charting pane

• Image of Chart
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Miscellaneous 

Updated Equation Editor dialog box to be 

resizable, added context-sensitive help by 

pressing F1 key, and reordered items in the 

Functions list to group similar items together.

Added ELTHK( elemID ; cornerID ), which 

returns planar element corner thicknesses.

Updated View->Options command to 

automatically switch Color Mode to appropriate 

“View Color” option after using Color Palette to 

select a color, then clicking OK

Updated selection of solids to allow use of the 

Select Visible icon, but only selects visible 

solids, not “Simcenter Femap volumes”
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Miscellaneous

Updated List->Geometry->Curve command to include Arc/Circle center coordinates when Advanced

option is enabled.

Improved Model->Merge to more cleanly handle cases where user intentionally chooses to 

overwrite existing entities in the current model.
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Simcenter Femap v2020.2 – What’s New

UI and Visualization – Miscellaneous 

Added ability to use commands on 

“floating” toolbars (i.e., not 

“docked”) while using another 

command. It was already possible 

to use commands on “docked” 

toolbars in previous versions.

Added “Group Display Mode” (i.e., 

Show Full Model, Show Active 

Group, and Show Multiple Groups) 

commands under “Additional 

Commands” on the Commands tab 

of the Customize dialog box. Once 

added to any toolbar, they can also 

have shortcut keys assigned
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Simcenter Femap v2020.2 – What’s New

Preprocessing – Beam Properties

Added Write Zeros at End B (Off=Blank) option for Nastran solvers to Beam Property 

If option is disabled, nothing is written to Nastran input 

file for that field, which means End B = End A for field
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Simcenter Femap v2020.2 – What’s New

Preprocessing – Tools

Tools->Parameters

• Added ability to specify 

Output Coordinate 

System to use for all 

newly created nodes

• Added ability to specify 

Color, Next ID, and Inc 

for Monitor Points

• Add ability to specify 

Next ID and Inc for 

Matrix Input entities
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Simcenter Femap v2020.2 – What’s New

Preprocessing – Tools

Tools->Mass Properties->Solid Properties

• Added support for multiple solids

• Support copying the listing to the 

Clipboard in Text, RTF, and HTML format

• Update the listing format to be similar to 

Tools->Mass Properties->Mesh 

Properties

• Supported computing overall properties 

and properties for individual solids. 

“Individual Solids” is only available if you 

select multiple “true solids” … no 

general or sheet bodies.

Added Mesh Options section to connect newly 

created representative mass element to any number 

of nodes in an existing mesh using either a single 

rigid element or multiple elements generated by 

Mesh->Connect->Closest Link functionality
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Simcenter Femap v2020.2 – What’s New

Preprocessing – Tools

Tools->Mass Properties->Mesh Properties

• Added support to copy the listing to the Clipboard in Text, 

RTF, and HTML format

• Added support for Solid Laminates Elements

• Laminate Layup thicknesses are scaled to match the 

length of each edge in the layup direction. Each ply is 

then computed as a “thin” single material brick/wedge with 

corners at the correct top/bottom ply locations.

• NOTE: CG computations will not match Nastran unless you use 

PARAM,COUPMASS,1.  This is an error in Nastran, not Simcenter Femap. 

See PR# 9631432.   Also, inertias will not match, just like all of the Simcenter 

Femap inertia computations, we simply use a lumped mass at the centroid 

and do not account for the inertia of the individual element geometry.
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Simcenter Femap v2020.2 – What’s New

Preprocessing – Loads and Boundary Conditions

Added ability to create Follower Forces 

and Follower Moments (Nastran Only)

• Define a force or moment in terms of 

a magnitude and direction nodes

• 2 nodes/points can be specified to 

define the direction of the of the load 

terms of a vector. 

• 4 nodes/points can be specified to 

define the direction as normal to a 

plane

• Both nodal and geometric follower 

loads can be defined 
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Simcenter Femap v2020.2 – What’s New

Meshing Toolbox – Feature Removal Tool

Added Preview option to Feature Removal 

Blends.

• Brings up surface entity select dialog with all 

found blends highlighted.

• Ability to add or remove specific blends. 

• Can be used with or without Limit Size.



Unrestricted © Siemens 2020
Siemens Digital Industries Software

Simcenter Femap v2020.2 – What’s New

Meshing Toolbox – Feature Removal Tool



Unrestricted © Siemens 2020
Siemens Digital Industries Software

Simcenter Femap v2020.2 – What’s New

Meshing Toolbox – Geometry Editing Tool

Added Surface/Replace Face capability to Extend under 

Geometry Editing.

• Extend faces of solid up to selected surface.

• Remove fillets that have failed from blend removal. 

• Raise or retract surfaces to main solid to remove 

features. 

• Existing extend commands are now under Curve on 

Surface.
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Simcenter Femap v2020.2 – What’s New

Geometry Editing Tool – Surface/Replace Face Workflow

Select

Surface to Extend to
Select Surfaces to Extend
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Simcenter Femap v2020.2 – What’s New

Geometry Editing Tool – Surface/Replace Face Workflow
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Simcenter Femap v2020.2 – What’s New

Geometry Editing Tool – Surface/Replace Face Workflow
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Simcenter Femap v2020.2 – What’s New

Meshing – Mesh Editing

• Updated various Mesh Editing commands to more fully and consistently handle the other entities 

associated and/or related to the elements being edited

• Commands that have been updated include:

• Mesh->Editing->Interactive

• Mesh->Editing->Split

• Mesh->Editing->Element Refine

• Mesh->Editing->Edge Split

• Features that are supported across these commands include:

• Updating Nodal Constraints and Nodal Permanent Constraints

• Updating Loads (On Faces, Corner Pressures, On Edges, Distributed Line)

• Updating Regions (both Nodal and Elemental)

• Updating Tapered Beam Shapes, Beam Offsets, Plate Thickness and Material Direction

• Updating Groups

• Updating Geometric Associativity
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Simcenter Femap v2020.2 – What’s New

Meshing – Miscellaneous

• Mesh Sizing

• Improved consistency when setting Mesh Sizes on curves using Element Size

• Previously two curves of seemingly similar length could end up with a different number of 

elements (+/- 1) due to very small length differences. 

• Combined Curve Creation (typically done to improve mesh quality)

• Only allow creation of Combined Curves if all underlying curves have the same manifold 

type (i.e., all curves are Free Edge, Manifold, NonManifold or Wirebody).
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Simcenter Femap v2020.2 – What’s New

Postprocessing – Send to Excel

• List->Output->Results to Excel

• Automatically opens Excel to 

transfer a variety of Results 

very quickly

• Take advantage of:

• Row / Column control

• Alternate column order

• Formatting style

• Transformation of Output 

Data

• Transfer Nodal and/or 

Elemental Results at same 

time
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Simcenter Femap v2020.2 – What’s New

Postprocessing – Send to Excel

When Formatting option 

is enabled, each 

worksheet in Excel will 

include:

• Column Filters

• Frozen Row Heading

• Frozen ID Column

• Nodal and Elemental 

results organized by 

different sheets
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added support to display Aero Pressures from Static Aeroelasity (SOL 144) analysis (*.f06 file only)
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added support to display Aero Coefficients from Static Aeroelasity (SOL 144) analysis (*.f06 file only)
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added support to display Aero Forces generated by Static Aeroelasity (SOL 144) analysis (*.f06 file only)
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added support for Shell Thickness Output (requested by SHELLTHK) from Simcenter Nastran SOL 402 

Step 1 Thickness: Max = 1.4E-04; Min 1.367E-04 Step 12 Thickness: Max = 1.399E-04; Min 5.386E-05
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added support for Plastic Strain Output (requested by PLSTRN) from Simcenter Nastran SOL 401/402 

Step 1 Plastic Strain: Max = 0.05193; Min 0.0 Step 12 Plastic Strain: Max = 0.9703; Min 0.0
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added support for progressive failure results output (requested by PFRESULTS) from SOL401/SOL402
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Failure results include Damage Status, Damage Values, Damage Energy, and Crack Density 

Time 0.2 Damage Energy: Max = 9.41E-4; Min -0.435E-4 Time 0.3 Damage Energy: Max = 4.27E-3; Min -2.89E-3
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Step 1 Ply D12: Max = 0.0; Min 0.0 Time 0.33 Ply D12: Max = 5.94E-1; Min -5.88E-2

Failure results include Damage Status, Damage Values, Damage Energy, and Crack Density 
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Added an option to Results tab of File-> 

Preferences to allow computing 

Averaged Midplane Stress and Strain.

• Simple average of Top and Bottom 

Results.

• Includes computation of Invariants 

from averaged mid values.

• Supported for Results either Read 

into the Database or Attached.

• Not supported for Complex 

Results.
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Simcenter Femap v2020.2 – What’s New

Post-Processing

Stress Linearization

• ASME Boiler and Pressure 

Vessel Code, 2007 SECTION 

VIII, DIVISION 2, ANNEX 5.1 

LINEARIZATION OF STRESS 

RESULTS FOR STRESS 

CLASSIFICATION

• Calculates a Linearized 

Membrane, Linearized 

Bending, and Peak Stresses 

along a Stress Classification 

(SCL)
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Simcenter Femap v2020.2 – What’s New

Post-Processing

Stress Linearization Process per the ASME 

Code

• Choice of the SCL is critical, user should 

be familiar with criteria for a proper SCL 

as defined in the ASME standard

• Stress tensor extracted from the FEA results 

is transformed to be aligned with the SCL

• Linearized Membrane Stress tensor 

components are the average of each along 

the SCL

• Linearized Bending Stress tensor only 

includes Hoop and Normal axial stress, and 

Hoop/Normal shear stress
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Simcenter Femap v2020.2 – What’s New

Post-Processing

Stress Linearization Process in Femap

• Choose Output Set

• Choose Linear or Nonlinear Results for the 

Stress Tensor

• Element Type for Stress Data

• Von Mises or Tresca Stress

• Pick Nodes for the Stress Classification Line 

(SCL)

• Calculate
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Simcenter Femap v2020.2 – What’s New

Post-Processing

Stress Linearization Results

• Chart showing the actual stress along the 

SCL

• Calculated Membrane, Bending, 

Membrane + Bending, Maximum 

Membrane + Bending

• Copy to Clipboard Option

• Exact Data values can also be copied 

from the Femap Chart
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Simcenter Femap v2020.2 – What’s New

Post-Processing

Stress Linearization Notes

• Full Component Bending option allows 

you to process the linearization with all 

components of the stress tensor 

considered for the bending stress 

calculations

• Tresca Stress – calculates a “Tresca” 

failure criterion stress value, which is 

based on the maximum shear stress, the 

Tresca Stress calculated by the tool is 2 

times maximum shear
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Simcenter Femap v2020.2 – What’s New

Postprocessing

Stress Classification Line (SCL) from Node 8185 to Node 8265
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Simcenter Femap v2020.2 – What’s New

Solver Support – Nastran Solvers

Added support for the General Element 

capability (GENEL)

• Define a substructure in terms of 

empirically-determined structural data

• Table interface for defining deflection 

influence or stiffness matrixes

• Graphical representation drawn that 

represents the connected DOFs 

connected to the constrained DOFs
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Simcenter Femap v2020.2 – What’s New

Solver Support – Nastran Solvers

Added support for Follower Forces and 

Follower Moments

• When 2 nodes/points are specified to 

define the direction of the the load in 

terms of a vector, writes FORCE1 or 

MOMENT1 

• When 4 nodes/points are specified to 

define the direction as normal to a plane, 

writes FORCE2 or MOMENT2

• Typically used by SOL 106, SOL 401, 

and SOL 402 for analysis which includes 

large deformation
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Simcenter Femap v2020.2 – What’s New

Solver Support – Simcenter Nastran

Added new nonlinear contact and control 

parameters for SOL402 

• New function types to specify type of 

exported stress-strain measures for 

SOL 402 (engineering vs. true) 

• New option to consider thickness and 

Z-offset for shell elements involved in 

contact
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Simcenter Femap v2020.2 – What’s New

Solver Support – Simcenter Nastran

Added support for modeling progressive ply 

failure for solid laminates (MATDMG)

• New material types to specify 

unidirectional fiber reinforced ply 

damage model and enhanced 

unidirectional ply damage model

• New function type to specify nonlinear 

damage evolution law for in-plane shear 

(shear damage vs thermodynamic force)

• Compute damage values, energy, status 

and crack density to predict failure
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Simcenter Femap v2020.2 – What’s New

Solver Support – ANSYS Updates

Added several options to Model Control section of ANSYS 

Command and Model Control dialog box

• Added Skip Csys, Skip Nodes, Skip Materials, Skip 

Properties, and Skip Elements - allows user to skip any 

combination of these entity types entirely during export

• Added Skip Groups – allows user to skip writing ESEL, 

NSEL and CM entries during export

• Added Skip Misc – allows user to skip view settings 

(/VIEW, /ANGLE, /ZOOM, etc), preprocessor commands 

(/NOPR, /FCOMP, /PREP7, /GOPR, etc), solution settings 

(/SOLU, ANTYPE, EQSLV, etc), SOLVE, FINISH, etc

• Changed Skip Beam/Bar Cross Sections to Skip Shapes
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Simcenter Femap v2020.2 – What’s New

Solver Support – ANSYS Updates

Added Result Control section to select the File Compression 

Level for the ANSYS results file (*.RST File)

Added ability to read output data contained in ANSYS results 

files which use “Version 1” compression (ANSYS default)

Added Manual Control section to:

• ANSYS Command and Model Control

• ANSYS Load Step

• ANSYS Time Step Options

• ANSYS Modal Analysis Options

• ANSYS Harmonic Analysis Options

• ANSYS Random Vibration Analysis Options

• ANSYS Buckling Options

• ANSYS Nonlinear Options

• ANSYS Output Requests
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Simcenter Femap v2020.2 – What’s New

Solver Support – LS-Dyna Updates

Added several options to Model Control section of LS-DYNA 

Model Option dialog box

• Added Skip Csys, Skip Nodes, Skip Materials, Skip 

Properties, and Skip Elements - allows user to skip any 

combination of these entity types entirely during export

• Added Skip Groups – allows user to skip writing *SET_ 

entries during export

• Added Skip Functions – allows user to skip writing 

functions (*DEFINE_CURVE entries) during export

• Added Skip Misc – allows user to skip comments starting with “$”, *KEYWORD, *TITLE with 

corresponding “title”, *CONTROL TERMINATION with corresponding value, 

*DATABASE_BINARY_D3PLOT with corresponding value, *END, and other entries during export
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Solver Support – LS-Dyna and ABAQUS Updates

Added LS-Dyna Analysis Monitor to monitor solver progress, 

review solver files, and optionally import results

Added support Preserve Load/BC Sets option for ABAQUS

• When enabled, causes imported loads and boundary 

conditions which reference a SET to create a Load 

Definition or Constraint Definition in Femap

Added support to write all supported load/constraint types 

that are contained in a Load/Constraint Definition as a SET 

entry in the ABAQUS input file, if requested by enabling the 

Write All Groups as Sets option in the ABAQUS Model 

Options dialog box
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Agenda:
Performance Improvements

UI and Visualization

Preprocessing

Meshing

Post Processing

Solver Support

Miscellaneous
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API – Control Multiple Femap Sessions 

• API Developers can 

now control multiple 

Femap sessions 

simultaneously

• Including Excel VBA 

Developers

• Forward-compatible

• feAppRunningApplicationInfo() • feAppGetRunningApplication()
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API

New Tools

• Added a MergeTool Object (feMergeTool) that is similar to the existing CopyTool and MoveTool, but 

exposes the capabilities of the File->Merge Command

• Ability to select From Model by name

• Methods to toggle individual/groups of entity types to include

• Method to “Add Related” entities with “Add Associated” option

• Unique methods for each Orientation/Transform option

• Properties to specify Options

• Methods to create “Patterns” of merged entities (not in UI)
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API

Stress Linearization API Access

• Automate processing of different Stress 

Linearization scenarios

• Same options as GUI version

Output from API Script:

Maximum Stress =  17800.6378136816

Membrane Stress =  1225.44895224937

Bending Stress =  11939.3928698333
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API

New Application Methods

• Added feFileGetByName( ) that returns Model ID of an open model based on its filename.

• Added feEdgesOfFreeFaces( ) that returns pairs of node IDs along the edges of Free Faces of selected 

elements.

New Object Methods

• Added NextOnEntity( ) method to the LoadGeom, LoadMesh and BCGeom objects and NextOnNode( ) to the 

BCEqn object. These new methods allow you to retrieve multiple loads/constraints of different types on multiple 

entities.

• Added AddNodesOnFreeEdges( ) and AddNodesOnFreeFaces( ) to the Set object that add nodes on free edges 

or faces of selected elements to the Set.

• Added ComputeStdShape2( ) and ComputeGeneralShape2( ) to the Property object that allow you to specify 

whether to compute properties at End A or End B of a tapered beam property.
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